ブレンダー

*このコンテンツは、ベータ版のAI(人工知能)を使用して翻訳されており、エラーが含まれている可能性があります。このページを英語で表示するには、 こちら をクリックしてください。

ブレンダーは、モデリング、彫刻、テクスチャリング、アニメーションツールの幅広い機能を備えた無料のオープンソース3D制作スイートです。Linux、macOS、Windowsシステムで動作するこのクロスプラットフォームアプリケーションは、アバター、アクセサリー、Robloxゲーム用の3Dオブジェクトを作成したいクリエイターに人気の選択肢です。

これは決して包括的なリストではありませんが、以下のガイドでは、3D制作に必要なブレンダーのツールと機能に関する高レベルの情報、およびブレンダーとスタジオ間で3Dアートを設計する際のベストプラクティスガイダンスを提供します。

ファイル設定

Robloxプラットフォーム用にブレンダーで3Dアートを作成する前に、3Dオブジェクトが両方のアプリケーション間で移動する際に同じ位置、向き、スケールを維持できるように、ブレンダーとスタジオの設定を構成することが重要です。

単位の設定

デフォルトでは、ブレンダーとスタジオは長さを測定するために異なる主要単位を使用します:ブレンダーはメートル法をデフォルトとし、スタジオはスタッドをデフォルトとします。どちらのアプリケーションであっても、3Dオブジェクトが同じ測定値を保持するようにするためには、ブレンダーの単位をスタッドと一致させる必要があります。

ブレンダーの単位をRobloxのスタッド単位と互換性を持たせるには:

  1. プロパティエディタに移動し、左側のナビゲーションでシーンタブを選択します。

    Blender's Properties editor with the Scene tab highlighted.
  2. 単位のドロップダウンメニューをクリックしてコンテナを展開し、次に:

    1. 単位システムをなしに設定します。
    2. 回転を度に設定します。

インポート設定

3Dソフトウェアとアプリケーションは、3D空間内のオブジェクトの位置と向きを表現するために座標系を使用します。これらの座標系は通常、3つの軸で構成されています:

  • 1つの軸は水平方向の位置(左右の動き)を表します。
  • 1つの軸は垂直方向の位置(上下の動き)を表します。
  • 1つの軸は深さ(前後の動き)を表します。

ブレンダーとスタジオは、"上"の方向を表す軸に関して異なる座標系を使用します。他のモデリングソフトウェアと同様に、ブレンダーはZ軸を使用します。なぜなら、3Dオブジェクトは2D平面から上に移動して3Dオブジェクトになるからです。一方、他のエンジンと同様に、スタジオはY軸を使用します。なぜなら、キャラクターは地面の平面上で移動し、垂直方向の動きのために上にジャンプするからです。

この違いは、3DアートをBlenderまたはStudioにインポートする際に重要です。オブジェクトがどちらのアプリケーションでも正しい向きを維持するために、インポート設定を調整する必要があります。

Blenderのナビゲーションギズモ
Studioのビューセレクター

StudioからBlenderへ

Studioから3DオブジェクトのBlenderインポート設定を行うには:

  1. 左上隅のハンバーガーメニューをクリックします。ポップアップメニューが表示されます。

  2. ファイル > インポート > Wavefront (.obj)、FBX (.fbx)、または**glTF 2.0 (.glb/.gltf)**に移動します。Blenderファイルビューウィンドウが表示されます。

  3. インポートしたい1つまたは複数の.obj、.fbx、または.gltfファイルを選択します。

  4. 右側のパネルで、一般セクションに移動します:

    1. スケールを1に設定して、Studioから同じスケールを維持します。
    2. 前方軸をZに設定して、Studioと同じ「前方」軸を維持します。
    3. 上方軸をYに設定して、Studioと同じ「上方」軸を維持します。
    The Blender File View window with the General section highlighted.
  5. 右下隅で、インポートボタンをクリックします。

BlenderからStudioへ

Blenderから3DオブジェクトのStudioインポート設定を行うには:

  1. ファイル > インポートに移動します。ローカルファイルブラウザが表示されます。

  2. ローカルシステムからインポートしたい3Dオブジェクトの.obj、.fbx、または.gltfファイルを選択して確認します。インポーターのインポートプレビューウィンドウが表示されます。

  3. 右側のパネルで、ファイル一般セクションに移動し、次に:

    1. 複数のオブジェクトをモデルとしてのみインポートしたい場合は、Modelオブジェクトにグループ化するためにこのオプションを有効にしてください。
    2. プロジェクト間で参照できるアセットIDを持つアセットを作成したい場合は、Robloxにアップロードを有効にします。
    3. オブジェクトにアクセスする必要があるのが自分だけの場合は Creator を Me に設定するか、作業しているプロジェクトを所有しているグループに設定します。この後者の設定により、すべての適格なグループメンバーがプロジェクト内で3Dオブジェクトを使用する権限を持つことが保証されます。
    4. Insert Using Scene Position を有効にして、オブジェクトがBlenderで設定した位置を保持するようにします。
    The Import Preview window with the File General section highlighted.
  4. File Transform セクションに移動し、オブジェクトがBlenderから同じ向きを保持するように以下の設定を行います:

    1. World Forward を Front に設定して、Blenderと同じ「前方」軸を保持します。
    2. World Up を Top に設定して、Blenderと同じ「上」軸を保持します。
  5. File Geometry セクションに移動し、 Scale Unit を Stud に設定して、Blenderから同じスケールを保持します。

  6. ウィンドウの下部で、 Import ボタンをクリックします。あなたの3DオブジェクトはBlenderから同じスケールと向きでインポートされます。

エクスポート設定

前のファイル設定セクションと同様に、Blenderから3Dアートをエクスポートする準備ができたときに、BlenderとStudioの異なる座標系を考慮することが重要です。エクスポート設定を構成するのに少し余分な時間をかけることで、3DオブジェクトがStudioにインポートしたときに正しい向き、スケール、位置を維持することができます。

Studio用に3DオブジェクトをエクスポートするためのBlender設定を行うには:

  1. 左上隅でハンバーガーメニューをクリックします。ポップアップメニューが表示されます。

  2. File > Export > Wavefront (.obj)、 FBX (.fbx)、または glTF 2.0 (.glb/.gltf) に移動します。 Blender File View ウィンドウが表示されます。

  3. 右側のパネルで、 Include セクションに移動し、 Limit to Selected Objects を有効にして、選択したオブジェクトのみをエクスポートします。

    The Blender File View window with the General section highlighted.
  4. Transform セクションで

    1. エクスポートする場合は .fbx、スケーリングを適用 を FBXユニットスケール に設定して、オブジェクトがスタジオで同じスケールを維持するようにします。スケーリングに関する詳細は、スケールを調整 を参照してください。
    2. Forward を Z Forward に設定して、Blenderと同じ「前方」軸を保持します。
    3. Up を Y Up に設定して、Blenderと同じ「上」軸を保持します。
  5. 右下隅で Export ボタンをクリックします。あなたの3Dオブジェクトは今、 Studioにインポートする 準備が整いました。

スケールの調整 (FBX)

FBX (.fbx) ファイル形式は、モデリングツールやエンジンでの広範なサポートにより、3Dワークフローで広く使用されています。しかし、Blenderからデフォルトの .fbx 設定を使用してエクスポートすると、モデルがRoblox Studioに予期しない大きなスケールでインポートされることがよくあります。

Two default Blender cubes imported in Studio with different scales.

ワークフローで .fbx に依存している場合、適切なエクスポート設定やプロジェクト設定が重要であり、モデルが正しいサイズで表示され、プラットフォーム間で意図した比率を維持することができます。

モデルを構成して、.fbx モデルがStudioで期待通りにスケールされるようにする方法はたくさんあります。スケーリングを管理するための一般的な設定を以下に示します:

Blender設定UI説明
エクスポート時に、Transform > Apply ScalingをFBX Unit Scaleに設定します。Two default Blender cubes imported in Studio with different scales.この設定でエクスポートされたモデルは、StudioまたはBlenderに同じスケールでインポートされます。

プロジェクトまたはエクスポート設定の他のすべてのスケーリング値がデフォルト (1.0) に設定されていることを確認してください。

これは、同じスケールで .fbx ファイルをエクスポートするための推奨方法です。
エクスポート時に、Transform > Scaleを**.01**に設定します。Two default Blender cubes imported in Studio with different scales.これにより、エクスポートが縮小され、モデルがStudioに期待通りのスケールでインポートされます。

このモデルをBlenderや他の非Studioツールに再インポートする予定がある場合、インポート時にモデルを拡大する必要があるかもしれません。そうしないと、モデルが予期しないほど小さくインポートされます。
シーンプロパティパネルで、Units > Unit Scaleを.01に設定します。Two default Blender cubes imported in Studio with different scales.これにより、シーン全体が縮小され、モデルが期待されるスケールでスタジオにインポートされます。シーンの単位を調整した場合、デフォルト設定を使用してモデルをスタジオにエクスポートできます。

.01スケールでモデルを作業すると、カメラの問題、モディファイアの問題、またはその他の複雑さなど、予期しないBlenderの問題が発生する可能性があります。

このモデルを再度Blenderにインポートする予定がある場合、インポート時にモデルを拡大する必要があるかもしれません。そうしないと、モデルが予期せず小さくインポートされます。

基本

Studio用の3Dアートを作成するための一般的なモデリング、スカルプティング、テクスチャリングツールを見ていく前に、アプリケーションをナビゲートし、特定の3D作成タスクに適したメニューやコントロールを見つけるために重要なBlenderの基本的なインターフェース要素を確認しましょう。

ワークスペース

Blender's UI with workspaces highlighted.

ワークスペースは、モデリング、スカルプティング、テクスチャリングなど、さまざまな3D作成作業のための専門的なUI構成とツールを持つプリセットウィンドウレイアウトです。これらのワークスペース構成をそのまま使用することも、異なるタスク間を迅速に切り替えるためにカスタマイズすることもできます。

多くのデフォルトのワークスペースがありますが、Robloxプラットフォーム用の3Dアートを作成するために最も一般的なものは以下の通りです。

Blender's Topbar with the Layout workspace highlighted.

レイアウトワークスペースは、Blenderファイルを読み込むときのデフォルトのワークスペースであり、3Dオブジェクトのプレビューや変形のための基本的なツールを提供します。これには、移動、スケール、回転ツールが含まれます。このワークスペースのデフォルトレイアウトには、3Dアートを設定する際に簡単にアクセスできる以下のUIが含まれています:

  • 3Dビューポート - シーン全体を表示します。
  • アウトライナー - シーン内のすべてのオブジェクトを表示し、Studioのエクスプローラーウィンドウに相当します。
  • プロパティエディタ - アクティブオブジェクトの編集可能なデータを表示し、Studioのプロパティウィンドウに相当します。
  • タイムラインエディタ - すべてのアニメーションキーフレームを表示し、アニメーションエディタのタイムラインに相当します。

3D Viewport

Blender's UI with the 3D Viewport highlighted.

Studioのビューポートに相当する 3D Viewport は、3D空間に存在する3Dオブジェクトを表示し、対話することができます。シーンをナビゲートし、マウスでオブジェクトを変形させ、3Dアートをデザインする際にリアルタイムで変更を確認できます。

モード

Blender's UI with the Modes selector highlighted.

Modes は、3D Viewportで3Dオブジェクトを編集するための追加ツールを提供します。モードセレクタから新しいモードを選択すると:

  • ヘッダーに新しいメニューオプションが表示されます。
  • ツールバーに新しいツールセットが表示されます。
  • エディターとそのボタンやパネルは、適切に有効または無効にします。

アクティブなモードによって、カーソルがブラシに変わることがあります。たとえば、ペイントモードやスカルプトモードでは、3Dビューポートが特定のタスクに対してオブジェクトの表示方法を変更し、オブジェクトを暗くしてペイントストロークをより見やすくすることができます。Blenderを学ぶ際には、さまざまなモードを試して、特定の3D制作タスクに利用できるツールを確認することが役立ちます。

Blender's Modes selector with the Object Mode menu item highlighted.

オブジェクトモード はデフォルトのモードであり、すべてのオブジェクトタイプに利用できるツールを提供します。これには、頂点、エッジ、面の位置決め、オブジェクトの回転やスケーリング、距離や角度の測定が含まれます。このモードは、高レベルのオブジェクト変換に役立ちます。

ツールバー

Blender's UI with the Toolbar highlighted.

ツールバー は、3Dビューポートの左側にある縦型のツールメニューです。モードを切り替えるたびに、ツールバーはその特定のモードに対して新しいユニークなツールセットを表示します。

3Dカーソル

Blender's UI with the 3D Cursor highlighted.

3Dカーソル は、位置と回転データを持つ3D空間内の可動参照点です。このツールにはさまざまな用途がありますが、最も一般的な用途は、その位置と向きを使用して:

  • 正確な変換を作成する。
  • 新しいオブジェクトをシーンに配置する。
  • オブジェクトやその頂点を3D空間内の新しいポイントに移動する。
  • ピボットポイントの位置を再配置する。

モデリングツール

ユーザーインターフェースのナビゲート方法と、特定の3D作成タスクに応じてツールを変更する方法を理解したので、3Dオブジェクトの形状を変更するための最も一般的なモデリングツールを詳しく見ていきましょう。これらのツールは、メッシュ全体またはメッシュの3つの基本要素のいずれかに影響を与えることができます。

  • 頂点 - メッシュ上の単一の点。
  • エッジ - 2つの頂点を結ぶ線。
  • 面 - 3つ以上の頂点の間の表面積。

以下の各セクションでは、オブジェクトやメッシュ要素に対して各ツールをどのように使用できるか、ツールをアクティブにするために使用できるホットキー、およびRobloxプラットフォーム用の3Dアートを作成する際の最も一般的な使用例について詳しく説明します。

A single active vertex on a cube mesh.
頂点
A single active edge on a cube mesh.
エッジ
A single active face on a cube mesh.
面

グラブ

グラブツールを使用すると、3D空間からオブジェクト、頂点、エッジ、面を移動できます。これは、シーン内のオブジェクトやメッシュ要素の位置を調整するための最も重要なツールの1つです。多くのRobloxクリエイターは、このツールを使用して、3D空間内の特定のスタッドユニットに頂点、エッジ、面を配置するなどの編集作業を行います。

グラブツールを使用するには:

  1. オブジェクトモードまたは編集モードで、1つまたは複数のオブジェクト、頂点、エッジ、または面を選択します。
  2. ツールをアクティブにするには、Gを押します。
  3. マウスを動かして選択を再配置します。さらに精度を高めるには:
    • X、Y、またはZをGを押した後に押すことで、それぞれX、Y、またはZ軸に沿った動きを制約できます。
    • 軸キーをダブルプレスすると、頂点やエッジをその自然な経路に沿ってスライドさせることができます。
    • マウスを動かしている間にShiftを押し続けると、微調整のために動きを遅くすることができます。
  4. 新しい位置を確認するには、左クリックするか、Enterを押します。

スナップ

スナップツールを使用すると、他のオブジェクト、メッシュ要素、または3D空間のグリッドにスナップすることで、オブジェクトやメッシュ要素を整列させることができます。このツールは、多くのRobloxクリエイターがシーン内で複数のオブジェクトを正確に配置し、特に位置、向き、スケールに関して、環境内でどのように機能するかを評価するために使用します。

スナップツールを使用するには:

  1. オブジェクトまたは編集モードで、ヘッダーに移動し、次にスナッピングボタンをクリックします。コンテキストメニューが表示されます。
Blender's header with the Snapping button highlighted.
  1. コンテキストメニューで、
    1. スナップベースを次のいずれかに設定します:
      • 最も近い - ターゲットに最も近い頂点を使用してスナップします。
      • 中心 - ピボットポイントを使用してスナップします。
      • 中央値 - 選択の中央値を使用してスナップします。
      • アクティブ - オブジェクトモードでは、この設定はアクティブ要素の原点を使用してスナップします。編集モードでは、この設定はアクティブ要素の中心を使用してスナップします。
    2. スナップターゲットを次のいずれかに設定します:
      • 増分 - 選択の位置からグリッドポイントにスナップします。
      • グリッド - 3Dビューポートのグリッドにスナップします。
      • 頂点 - マウスカーソルに最も近い頂点にスナップします。
      • エッジ - マウスカーソルに最も近いエッジにスナップします。
      • 面 - マウスカーソルに最も近い面にスナップします。
      • ボリューム - 選択をカーソルの下にあるオブジェクトの中心に配置された深さにスナップします。
      • エッジセンター - マウスカーソルに最も近いエッジの中心点にスナップします。
      • エッジ垂直 - 選択の元の位置から新しい位置への線がそのエッジに垂直になるように、エッジ上の特定の点にスナップします。
    3. 影響を次のいずれかに設定します:
      • 移動 - 選択を移動中にスナップします。
      • 回転 - 選択を回転中にスナップします。
      • スケール - 選択をスケーリング中にスナップします。
  2. ShiftTabを押してツールをアクティブにします。
  3. さらに精度を高めるために、Shiftを押しながら選択を細かい増分でスナップします。
  4. 設定に従ってオブジェクトまたはメッシュ要素を移動、回転、またはスケールします。

インセット

インセットツールを使用すると、面または面のグループから調整可能な厚さと深さのインセットを作成できます。多くのRobloxクリエイターは、このツールを使用してメッシュの均一な細部を作成し、トポロジーのクリーンなエッジフローを維持しています。

インセットツールを使用するには:

  1. 編集モードで、1つまたは複数の面を選択します。
  2. Iを押してツールをアクティブにします。
  3. マウスを動かしてインセットのサイズを調整します。さらに精度を高めるために:
    • Ctrlを押しながらインセットの深さを調整します。
    • マウスを動かしながらShiftを押すと、微調整のために動きを遅くします。
    • 再度Iを押して、各アクティブな面をインセットします。
  4. 左クリックするか、Enterを押してインセットを確認します。

押し出し

押し出しツールを使用すると、既存のジオメトリから新しい面、エッジ、または頂点を引き出して新しいジオメトリを作成できます。多くのRobloxクリエイターは、このツールを使用してBlenderのプリミティブメッシュから深さ、ボリューム、および複雑な形状を作成します。

押し出しツールを使用するには:

  1. 編集モードで、1つまたは複数の頂点、エッジ、または面を選択します。
  2. Eを押してツールをアクティブにします。
  3. マウスを動かして押し出しの長さを調整します。さらに精度を高めるために、 X、 Y、または Zを押した後に Eを押すことで、それぞれ X、 Y、または Z軸に動きを制約できます。
  4. 左クリックするか、 Enterを押して押し出しを確認します。

細分化

細分化ツールを使用すると、エッジや面を小さな区分に切り分けることができ、新しい頂点とメッシュの解像度が追加されます。多くのRobloxクリエイターは、このツールを使用して滑らかな曲線を作成したり、表面に細かいディテールを追加したり、追加のモディファイアを適用する前にメッシュを準備したりします。

細分化ツールを使用するには:

  1. 編集モードで、1つまたは複数のエッジまたは面を選択します。

  2. 右クリックしてアクティブなエッジまたは面のコンテキストメニューを表示し、次に 細分化を選択してツールをアクティブにします。細分化パネルが表示されます。

  3. カット数をエッジまたは面の細分化数に設定します。

    The Subdivide panel with the Number of Cuts setting highlighted.
  4. 左クリックして細分化を確認します。

ブリッジエッジループ

ブリッジエッジループツールを使用すると、複数のエッジループを面で接続できます。多くのクリエイターは、このツールを使用して手動で新しい面を作成することなく隙間を埋めたり、メッシュの複雑な部分を統合したり、滑らかな変形のためにクリーンなトポロジーを維持したりします。

Bridge Edge Loopsツールを使用するには:

  1. Editモードで、接続したい2つ以上のエッジループを選択します。
  2. CtrlE/⌘Eを押して、アクティブなエッジループのコンテキストメニューを表示し、次に Bridge Edge Loopsを選択してツールをアクティブにします。 Bridge Edge Loopsパネルが表示されます。
  3. Number of Cutsを新しいブリッジのサブディビジョン数に設定します。
  4. OPTIONAL
    曲線ブリッジの精度をさらに高めるために、 Smoothnessを増やして、より丸みを帯びたブリッジを作成します。
  5. 左クリックしてブリッジを確認します。

フィル

Fillツールを使用すると、アクティブなエッジまたは頂点の間に三角形の面を作成できます。これらは1つ以上の完全な周囲を形成する限りです。多くのRobloxクリエイターは、このツールを使用してメッシュの隙間を閉じ、完全に密閉された状態にしたり、露出した穴をなくしたりします。

フィルツールを使用するには:

  1. Editモードで、少なくとも3つの頂点または2つ以上のエッジを選択し、少なくとも1つの完全な周囲を形成します。
  2. AltF/⌥Fを押してツールをアクティブにします。
  3. OPTIONAL
    Fill パネルで、三角形をきれいに配置するために Beauty を有効にします。
  4. 左クリックして新しい面を確認します。

エッジからの新しい面

New Faces from Edgesツールを使用すると、2つの頂点がアクティブな場合はエッジを作成し、そうでない場合はアクティブなメッシュ要素の間に面を作成します。多くのRobloxクリエイターは、このツールを使用してメッシュの隙間を一度に閉じ、メッシュを完全に密閉したり、多くの孤立した頂点の間にジオメトリを作成したりします。

エッジからの新しい面ツールを使用するには:

  1. Editモードで、少なくとも3つの頂点または1つ以上の完全な周囲を形成する2つ以上のエッジを選択します。
  2. Fを押してツールをアクティブにします。
  3. 左クリックして新しい面を確認します。

溶解

溶解 ツールを使用すると、メッシュに穴を残さずにジオメトリを削除できます。多くのRobloxクリエイターは、このツールを使用して3Dアートを最適化したり、ジオメトリを統合したり、メッシュの全体構造を保持しながら不要なメッシュ要素を削除したりします。

溶解ツールを使用するには:

  1. 編集 モードで、メッシュから削除したい頂点、エッジ、または面を選択します。
  2. 右クリックしてアクティブなメッシュ要素のコンテキストメニューを表示し、次に:
    1. 選択が頂点で構成されている場合は、頂点を溶解を選択して、アクティブな頂点を削除し、隣接するエッジを統合します。
    2. 選択がエッジで構成されている場合は、エッジを溶解を選択して、アクティブなエッジを削除し、周囲の面を結合してエッジの輪郭を維持します。
    3. 選択が面で構成されている場合は、面を溶解を選択して、アクティブな面を削除し、必要に応じて新しい面で隙間を埋めます。

削除

削除 ツールを使用すると、メッシュからジオメトリを完全に削除でき、ジオメトリが削除された場所に1つまたは複数の穴が残ります。多くのRobloxクリエイターは、反復プロセス中にメッシュを再構築したいときに、溶解ツールの代わりにこのツールを使用します。

削除ツールを使用するには:

  1. 編集 モードで、メッシュから削除したい頂点、エッジ、または面を選択します。
  2. Xを押して、選択のコンテキストメニューを表示します。
  3. 次のメニュー項目のいずれかを選択します:
    1. 頂点を選択して、すべてのアクティブな頂点を削除し、それらに接続されている面やエッジを削除します。
    2. エッジを選択して、すべてのアクティブなエッジを削除し、そのエッジと共有している面を削除します。
    3. 面を選択して、すべてのアクティブな面を削除し、それらに接続されているエッジを削除します。
    4. 選択して エッジと面のみ を選ぶと、アクティブなエッジと隣接する面だけを削除できます。
    5. 選択して 面のみ を選ぶと、アクティブなエッジに影響を与えずにすべてのアクティブな面を削除できます。

ミラーモディファイア

ミラーモディファイア を使用すると、ジオメトリを1つまたは複数の軸に沿ってミラーリングできるため、最小限の労力で対称的な3Dアートを作成できます。多くのRobloxクリエイターは、アバターや完璧に対称であることが重要な建築物のモデリング中にこのツールを使用します。

ミラーモディファイアを使用するには:

  1. オブジェクトモードで、ミラーリングしたいオブジェクトを選択します。

  2. プロパティエディタに移動し、左側のナビゲーションで モディファイア タブを選択します。

    Blender's Properties editor with the Modifiers tab highlighted.
  3. モディファイアを追加 ボタンをクリックし、 ミラー モディファイアを挿入します。

  4. 軸 を X、 Y、および/または Z に設定して、1つまたは複数の軸に沿ってミラーリングします。

  5. 編集モードで、オブジェクトまたはそのメッシュ要素を修正して、修正が1つまたは複数の軸に沿ってミラーリングされるのを確認します。

テクスチャリングツール

3Dオブジェクトのモデリングが完了したら、メッシュにテクスチャを適用して、色、深さ、粗さなどの追加の視覚的特性を持たせる時です。これは テクスチャマップ を通じて行われます。これらはモデリングだけでは提供できない詳細であり、オブジェクトを空白の形状から、ゲームのアート要件に応じてリアルまたはスタイライズされたものに変えます。

テクスチャなしのモデル
テクスチャ付きのモデル

以下の各セクションでは、UV編集または頂点ペイントオブジェクトのために各ツールを使用する方法、ツールをアクティブにするために使用できるホットキー、およびRobloxプラットフォームの3Dアートのテクスチャリングに最も一般的に使用されるケースを詳述します。

UV編集

UV編集は、3Dオブジェクトの面を展開し、それらを2D画像テクスチャにマッピングするプロセスです。このプロセスにより、単一のテクスチャを使用してBlender内の複数のオブジェクトに視覚的特性を適用でき、Studioでのメモリへの悪影響を軽減できます。たとえば、以下のドアフレーム、天井、および レーザータグ テンプレート内のカードリーダーメッシュは、すべて同じUVマップを使用して金属の装飾を追加しています。

An doorway with trim sheet textures applied.
A group of ceiling tiles with trim sheet textures applied.
A futuristic card reader with trim sheet textures applied.

UV編集の「UV」は、マッピングプロセス中に使用する2D画像マップの軸を指します:

  • U軸 - 水平方向の位置(左右の移動)。
  • V軸 - 垂直位置(上下の動き)。

3Dオブジェクトは3D空間でX、Y、Z軸を使用するため、2D画像空間の座標を参照する際に混乱を避けるために、3D作成アプリケーションでは通常UとVを使用します。それに言及すると、多くのBlenderのUIワークフローは依然としてXとYを使用しているため、2D空間の対応する軸を知っておくことは役立ちます。

3Dオブジェクトをアンラップすると、すべてのアクティブな面がUVエディタの2D空間に平坦化され、UVマップを構成し、モデルの異なるセクションが別々のグループに分割され、一般的にUVアイランドと呼ばれます。たとえば、標準のBlenderキューブをアンラップすると、各面はUVマップ内の独自のUVアイランドになります。

A UV map of a 3D cube.
UVエディタのUVマップ
The 3D cube that is being unwrapped.
3Dビューポートのキューブ

UVマップ内のすべての点、線、面は、メッシュ内の頂点、エッジ、面に対応しています。これは、UVアイランドをテクスチャの異なる部分に移動すると、それに対応する頂点、エッジ、面が更新され、現在重なっているテクスチャの領域を反映することを意味します。

Blenderは、歪みを最小限に抑え、テクスチャを適用しやすくするために、シームや接続されたエッジに沿ってUVアイランドを作成することがよくあります。このデフォルトのUVアイランド構成は素晴らしい出発点ですが、テクスチャを投影したい領域に重なるように各アイランドの位置、向き、スケールを変更することがほぼ常に必要です。また、特定の領域に焦点を当ててテクスチャリングを行うために、自分のシームをマークすることもできます。

UVアイランドをアンラップ、配置、マッピングするために時間を投資することで、テクスチャの品質を向上させ、すべての3Dアートでの引き伸ばしや歪みを減らすことができます。以下のサブセクションでは、このプロセスにおける最も一般的なツールを、特にオブジェクトのアンラップとマッピングに関して強調します。

シームをマーク

マークシームツールを使用すると、3DオブジェクトのUVマップを小さく管理しやすいセクションに手動で分割できます。このアンラッププロセスのステップは技術的にはオプションですが、多くのRobloxクリエイターは、詳細なテクスチャ作業が必要な複雑なオブジェクトの関連する面のコレクションに集中するために便利だと感じています。

たとえば、次のリベットガンは、バレルに金属テクスチャ、グリップにレザーテクスチャを必要とします。このオブジェクトのテクスチャを簡単にするために、グリップのシームをマークし、そのシームの間の面だけをアンラップし、次にそれをレザーテクスチャ画像にマッピングできます。

A UV map of a grip on a rivet gun.
グリップのUVマップをUVエディタで
The marked seams and enclosed faces on the rivet gun that are being unwrapped.
3Dビューポートのマークされたシーム

マークシームツールを使用するには:

  1. UV編集ワークスペースを開きます。UVエディタは画面の左側に表示され、3Dビューポートは画面の右側に編集モードで表示されます。
  2. 3Dビューポートで、3Dオブジェクトに移動し、シームを作成したいエッジを選択します。
  3. 次に、CtrlE/⌘Eを押して、エッジのコンテキストメニューを開きます。
  4. マークシームを選択します。シームが赤くなり、アンラップツールの準備が整います。

オブジェクトをアンラップする準備ができたら、Blenderはシームの囲まれた面を独自のアイランドとしてアンラップします。

アンラップ

Unwrap ツールを使用すると、3Dオブジェクトのマークされたシームやアクティブな面のUVマップをアンラップして整理することができ、作業するためのしっかりとしたUVアイランドの基盤を得ることができます。これにより、UV座標が完全に混乱した状態から、より管理しやすいものに迅速に変わります。

多くのRobloxクリエイターは、キャラクター、衣服、曲線のあるオブジェクトなど、テクスチャを適用する際に完全なコントロールが必要な複雑な形状にこのツールを使用しています。これは迅速に動作し、引き伸ばしや歪みを避けるためです。

A chaotic with disorganized islands.
アンラップツールを使用する前
A clean UV map with organized islands.
アンラップツールを使用した後

アンラップツールを使用するには:

  1. UV Editing ワークスペースを開きます。UVエディタは画面の左側に表示され、3Dビューポートは画面の右側にエディットモードで表示されます。
  2. 3D Viewport で、3Dオブジェクトに移動し、Mark Seam ツールを使用してシームを作成するか、テクスチャを適用したい特定の面を選択します。
  3. U を押して、UV Mapping コンテキストメニューを開きます。
  4. Unwrap を選択します。選択したUVアイランドがUVエディタにきれいに表示されます。
  5. UV Editor で、UVアイランドをテクスチャの適切な位置、方向、スケールに移動、スケール、または回転させます。

アクティブなクワッドに従う

Follow Active Quads ツールを使用すると、以前にアンラップされたアクティブな面のUV座標に基づいて、クリーンで整理されたUVアイランドを生成できます。これは、壁、床、またはトリムシートを使用した機械部品など、グリッド状のトポロジーをアンラップする際に特に便利です。

多くのRobloxクリエイターは、このツールを使用して、ゲーム用の歩道やアクセサリー用のベルトなど、曲線のある3Dオブジェクトに一貫したテクスチャを適用します。

Follow Active Quadsツールを使用するには:

  1. UV Editing ワークスペースを開きます。UVエディタは画面の左側に表示され、3Dビューポートは画面の右側にエディットモードで表示されます。
  2. 3D Viewport で、3Dオブジェクトに移動し、アクティブな面を使用してテクスチャを適用したいすべての面をアンラップします。
  3. OPTIONAL
    アクティブな面を設定します。
    1. UVエディタで、アクティブにしたい面を選択し、次にAltを押し、M/⌥を押してMを開き、分割のコンテキストメニューを表示します。
    2. 選択を選択します。アクティブな面がUVアイランドから分離されます。
    3. アクティブな面を適切な位置、方向、スケールに移動、スケール、または回転させて、他の面がUVマップで従うようにします。
  4. UVエディタで、アクティブな面に従うすべての面を選択します。Blenderがそのレイアウトをガイドとして使用するために、アクティブな面を最後に選択することを確認してください。
  5. Uを押してアンラップのコンテキストメニューを開き、次にアクティブな四角形に従うを選択します。Blenderは選択したUV座標をアクティブな面の形状と方向に合わせて整列させます。

投影

投影ツールは、3Dオブジェクトの表面を2D画像テクスチャ平面に投影するツールです。各投影ツールは、オブジェクトの形状がどのようにアンラップされ、2Dテクスチャにマッピングされるかを制御します:

  • キューブ投影 - オブジェクトの面をキューブのすべての6面に投影します。箱型の形状(クレートなど)に便利です。
  • 球体投影 - オブジェクトの表面を球体に投影します。目のような丸い形状に便利です。
  • 円柱投影 - オブジェクトを円柱形状に投影します。チューブ、パイプ、手足に便利です。
  • ビューからの投影 - 現在のカメラまたはビューポートの角度に従ってオブジェクトの選択した面を投影します。平面やデカールに便利です。
  • スマートUVプロジェクト - モデルを自動的にアンラップし、面の間の設定された角度に従ってアイランドを生成します。

投影ツールを利用してテクスチャリングプロセスの時間を節約する方法を考慮することは有益です。特に、繰り返しのテクスチャが必要な単純なオブジェクトに対してです。たとえば、多くのRobloxクリエイターは、エッジからシームをマークする必要なく、基本的な幾何学的形状のために効率的にUVアイランドを作成するためにこれらのツールを戦略的に使用しています。

A UV map using Smart UV Project.
スマートUVプロジェクトを使用したUVマップ.
A UV map using Cube Projection.
キューブ投影を使用したUVマップ.

投影ツールを使用するには:

  1. UV編集ワークスペースを開きます。UVエディタは画面の左側に表示され、3Dビューポートは画面の右側に表示され、編集モードになります。
  2. 3Dビューポートで、3Dオブジェクトに移動し、すべての面を選択します。
  3. Uを押してUVマッピングのコンテキストメニューを開き、次のオプションのいずれかを選択します:
    • キューブ投影
    • 球体投影
    • 円柱投影
    • ビューからの投影
    • スマートUV投影

バーテックスペイント

バーテックスペイントは、従来のテクスチャやマテリアルを使用するのではなく、3Dオブジェクトの頂点に直接色情報を保存するプロセスです。このアプローチでは、各頂点が色データを保持し、Blenderがメッシュの面全体に補間して滑らかなグラデーションや固体の色のブロックを作成します。UVマッピングや画像テクスチャは必要ありません。

バーテックスペイントは、特にパフォーマンスが重要なスタイライズされたワークフローやゲームにおいて、アセットに色のバリエーションを軽量かつ効率的に追加するのに役立ちます。これにより、テクスチャメモリの使用量や描画呼び出しを削減できます。多くのRobloxクリエイターは、スタジオのデフォルトマテリアル、MaterialVariantオブジェクト、SurfaceAppearanceオブジェクトと組み合わせて、シンプルな3Dオブジェクトに視覚的な複雑さを作り出しています。

A rocket launcher object in Blender without any color.
色のないオブジェクト
A rocket launcher object in Blender with vertex paint on the handle.
バーテックスペイントのあるオブジェクト
A rocket launcher object in Studio with vertex paint and a SurfaceAppearance texture
バーテックスペイントと画像テクスチャのあるオブジェクト

バーテックスペイントを行うには:

  1. オブジェクトの頂点に色情報を保存するためのカラ―属性を追加します。

    1. 3Dビューポートで、3Dオブジェクトを選択します。

    2. プロパティエディタに移動し、左側のナビゲーションでデータタブを選択します。

      Blender's Properties editor with the Data tab highlighted.
    3. カラー属性のドロップダウンメニューをクリックしてコンテナを展開し、次に**+**ボタンをクリックします。カラー属性を追加のコンテキストメニューが表示されます。

    4. ドメインを頂点に、データタイプをカラーに設定し、次に追加ボタンをクリックします。これでオブジェクトにカラー属性が追加されました。

  2. 3Dビューポートを設定して、カラー属性を表示します。

    1. 3Dビューポートで、右上隅のビューポートシェーディングオプションに移動し、ソリッドシェーディングモードのボタンをクリックします。

      Blender's Viewport Shading options with the Solid shading mode highlighted.
    2. ビューポートシェーディングのドロップダウン矢印をクリックし、コンテキストメニューでカラーを属性に設定します。3Dビューポートが更新され、オブジェクトにカラー属性が表示されます。

      Blender's Viewport Shading dropdown menu with the dropdown arrow and Color settings highlighted.
  3. ブラシの色を選択します。

    1. 頂点ペイントモードで、左上隅に移動し、アクティブなカラースウォッチをクリックします。コンテキストメニューが表示されます。

    2. カラーホイールで色を選択するか、RGB、HSV、またはHexコードを使用します。

      Blender's active swatch UI highlighted.
  4. オブジェクトに色を適用します。

    1. 個々の頂点に色を適用するには:
      1. 3Dビューポートで、オブジェクトの頂点の上をクリックしてドラッグし、滑らかなグラデーションで色を適用します。
      2. さらに精度を高めるために、[または]を押して、ブラシサイズをそれぞれ増減させます。
    2. 色をフラッドフィルするには、
      1. 編集モードで、色を適用したい頂点または面を選択します。
      2. 頂点ペイントモードで、Ctrl+X/⌘+Xを押します。選択した頂点または面に新しい色が表示されます。
©2026 Roblox Corporation。Roblox(ロブロックス)、RobloxロゴおよびPowering Imaginationは、米国並びにその他の国における登録商標および非登録商標です。